CLIでMauitcコアのバージョンを指定してアップデートする

諸刃の剣なのでまったくおすすめしませんが、できるのはできたのでメモ。
アドオンや運用時のローカルテストくらいにしか使えなさそうです。

手順

やり方は簡単で、古いバージョンのコアzipファイルを最新版のバージョン名で配置しておくだけです。

$ cd /PATH/TO/MAUTIC
$ wget https://github.com/mautic/mautic/releases/download/2.8.1/2.8.1.zip
$ mv 2.8.1-update.zip 2.10.1-update.zip
$ php upgrade.php
Checking for new updates...updating to 2.10.1!
Extracting the update package...done!
Moving files...done!
Clearing the cache...done!
Rebuilding the cache...done!
Applying migrations...done!
Cleaning up...done!

Success!

GUIからアクセスすると、2.8.1で動作していることが確認できます。

CLIからもアップデートが必要なバージョンであることを認識していることが確認できました。

# php app/console mautic:update:find
Mauticのバージョン 2.10.1 がダウンロード可能です。詳細は https://www.mautic.org/community/index.php/8475-2-10-1-released をお読みください。
アップデートするにはコマンドラインから'php app/console mautic:update:apply'を実行してください。

やっぱり最新版にしたい場合

偽装しているzipファイルを消してphp upgrade.phpを実行しましょう。
上記手順と同様にwgetなどで最新版のzipファイルを直接配置するのも1つです。

ただし

コアチームの意図している動きではないので、このアップデートで事故るケースの方がおそらく多いと思います。
Vagrant / Dockerなどの使い捨てにしてもいい環境で、バージョンを指定したテストしたい場合に使う程度にしてください。

2.9.2 -> 2.8.1 -> 2.10.1を試して出たエラー(一部)

# php app/console doctrine:migrations:migrate

  [Doctrine\ORM\Mapping\MappingException]
  Duplicate definition of column 'id' on entity 'Mautic\CoreBundle\Entity\MessageQueue' in a field or discriminator column mapping.

]# tail app/logs/mautic_prod-2017-10-25.php
[2017-10-25 17:25:07] mautic.ERROR: Symfony\Component\Debug\Exception\FatalErrorException: Notice: require(): Failed opening required '/var/www/html/app/cache/prod/doctrine/orm/Proxies/__CG__MauticStageBundleEntityStage.php' (include_path='.:/usr/share/pear:/usr/share/php') - in file /var/www/html/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 [] []
$ tail -f /var/log/httpd/ssl_error_log
[Wed Oct 25 08:30:26.615227 2017] [:error] [pid 3345] [client 210.170.194.219:52779] PHP Warning:  require(/var/www/html/app/cache/prod/doctrine/orm/Proxies/__CG__MauticStageBundleEntityStage.php): failed to open stream: No such file or directory in /var/www/html/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209, referer: https://13.114.212.68/s/login
[Wed Oct 25 08:30:26.615264 2017] [:error] [pid 3345] [client 210.170.194.219:52779] PHP Fatal error:  require(): Failed opening required '/var/www/html/app/cache/prod/doctrine/orm/Proxies/__CG__MauticStageBundleEntityStage.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/html/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209, referer: https://13.114.212.68/s/login

そもそも

最新版で動く様に使って欲しいなと思う次第です。