"Problem binding to port 443"でLet’s Encryptの証明書更新に失敗した場合の対応メモ

Let’s Encryptの証明書更新に失敗した時の対応メモとは別パターンのエラーに遭遇したのでこちらもメモ。

現象

an unexpected error: Problem binding to port 443: Could not bind to IPv4 or IPv6.. Skipping.というエラーで更新に失敗する。

# /usr/local/letsencrypt/letsencrypt-auto renew
Saving debug log to /var/log/letsencrypt/letsencrypt.log

-------------------------------------------------------------------------------
Processing /etc/letsencrypt/renewal/example.com.conf
-------------------------------------------------------------------------------
Cert is due for renewal, auto-renewing...
Plugins selected: Authenticator standalone, Installer None
Renewing an existing certificate
Performing the following challenges:
tls-sni-01 challenge for example.com
Cleaning up challenges
Attempting to renew cert (example.com) from /etc/letsencrypt/renewal/example.com.conf produced an unexpected error: Problem binding to port 443: Could not bind to IPv4 or IPv6.. Skipping.
All renewal attempts failed. The following certs could not be renewed:
  /etc/letsencrypt/live/example.com/fullchain.pem (failure)

-------------------------------------------------------------------------------

All renewal attempts failed. The following certs could not be renewed:
  /etc/letsencrypt/live/example.com/fullchain.pem (failure)
-------------------------------------------------------------------------------

対応

Trying to renew cert on nginx but getting “Problem binding to port 443: Could not bind to IPv4 or IPv6” – Let’s Encryptを見る限り、443ポートを使用しているサーバーを止めてから作業すると動く様子。

# service httpd stop
Stopping httpd:                                            [  OK  ]

更新

[root@ip-172-31-24-26 ~]# /usr/local/letsencrypt/letsencrypt-auto renew
Saving debug log to /var/log/letsencrypt/letsencrypt.log

-------------------------------------------------------------------------------
Processing /etc/letsencrypt/renewal/example.com.conf
-------------------------------------------------------------------------------
Cert is due for renewal, auto-renewing...
Plugins selected: Authenticator standalone, Installer None
Renewing an existing certificate
Performing the following challenges:
tls-sni-01 challenge for example.com
Waiting for verification...
Cleaning up challenges

-------------------------------------------------------------------------------
new certificate deployed without reload, fullchain is
/etc/letsencrypt/live/example.com/fullchain.pem
-------------------------------------------------------------------------------

-------------------------------------------------------------------------------

Congratulations, all renewals succeeded. The following certs have been renewed:
  /etc/letsencrypt/live/example.com/fullchain.pem (success)
-------------------------------------------------------------------------------

再起動

[root@ip-172-31-24-26 ~]# service httpd start
Starting httpd:                                            [  OK  ]

更新を確認

[root@ip-172-31-24-26 ~]# openssl x509 -noout -dates -in /etc/letsencrypt/live/example.com/fullchain.pem
notBefore=Oct 30 14:56:43 2017 GMT
notAfter=Jan 28 14:56:43 2018 GMT

CLIでMauticコアのアップデートが"Package could not be found!"となった場合の対応

Issueも立てているのですが、手動での対応法を覚書として残しておきます。

現象

2.9.xから2.10.1へのアップデート時に以下の様なエラーが出るケースがありました。

$ cd /PATH/TO/MAUTIC
$ php upgrade.php
Checking for new updates...updating to 2.10.1!
Extracting the update package...failed. Package could not be found!

コアのソースコードを見る限りでは、zipファイルの取得に失敗している様子です。

対応

Issueのコメントにて、「zip取れてないから、直接おいてやればいいよ」というコメントがありましたのでそれで対応しています。

$ wget https://github.com/mautic/mautic/releases/download/2.10.1/2.10.1.zip
$ mv 2.10.1.zip 2.10.1-update.zip
$ php upgrade.php
Checking for new updates...updating to 2.10.1!
Extracting the update package...done!
Moving files...done!
Clearing the cache...done!
Rebuilding the cache...done!
Applying migrations...done!
Cleaning up...done!

Success!

Mauticでは、{バージョン番号}-update.zipという命名規則でファイルがDLされます。(該当コードはこちら
ですのでzipファイルをDLして、その名前に変更してやることでアップデートスクリプトが問題なく実行される様になります。

そのほか

該当ファイルがある場合はDLせずにそのまま展開して実行していく様子です。
なのでリネーム時に最新版のバージョン名へ偽装すればバージョン指定のアップデートもできるのかもしれません。(おすすめはしませんが)

CLIでMauitcコアのバージョンを指定してアップデートする

諸刃の剣なのでまったくおすすめしませんが、できるのはできたのでメモ。
アドオンや運用時のローカルテストくらいにしか使えなさそうです。

手順

やり方は簡単で、古いバージョンのコアzipファイルを最新版のバージョン名で配置しておくだけです。

$ cd /PATH/TO/MAUTIC
$ wget https://github.com/mautic/mautic/releases/download/2.8.1/2.8.1.zip
$ mv 2.8.1-update.zip 2.10.1-update.zip
$ php upgrade.php
Checking for new updates...updating to 2.10.1!
Extracting the update package...done!
Moving files...done!
Clearing the cache...done!
Rebuilding the cache...done!
Applying migrations...done!
Cleaning up...done!

Success!

GUIからアクセスすると、2.8.1で動作していることが確認できます。

CLIからもアップデートが必要なバージョンであることを認識していることが確認できました。

# php app/console mautic:update:find
Mauticのバージョン 2.10.1 がダウンロード可能です。詳細は https://www.mautic.org/community/index.php/8475-2-10-1-released をお読みください。
アップデートするにはコマンドラインから'php app/console mautic:update:apply'を実行してください。

やっぱり最新版にしたい場合

偽装しているzipファイルを消してphp upgrade.phpを実行しましょう。
上記手順と同様にwgetなどで最新版のzipファイルを直接配置するのも1つです。

ただし

コアチームの意図している動きではないので、このアップデートで事故るケースの方がおそらく多いと思います。
Vagrant / Dockerなどの使い捨てにしてもいい環境で、バージョンを指定したテストしたい場合に使う程度にしてください。

2.9.2 -> 2.8.1 -> 2.10.1を試して出たエラー(一部)

# php app/console doctrine:migrations:migrate

  [Doctrine\ORM\Mapping\MappingException]
  Duplicate definition of column 'id' on entity 'Mautic\CoreBundle\Entity\MessageQueue' in a field or discriminator column mapping.

]# tail app/logs/mautic_prod-2017-10-25.php
[2017-10-25 17:25:07] mautic.ERROR: Symfony\Component\Debug\Exception\FatalErrorException: Notice: require(): Failed opening required '/var/www/html/app/cache/prod/doctrine/orm/Proxies/__CG__MauticStageBundleEntityStage.php' (include_path='.:/usr/share/pear:/usr/share/php') - in file /var/www/html/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php - at line 209 [] []
$ tail -f /var/log/httpd/ssl_error_log
[Wed Oct 25 08:30:26.615227 2017] [:error] [pid 3345] [client 210.170.194.219:52779] PHP Warning:  require(/var/www/html/app/cache/prod/doctrine/orm/Proxies/__CG__MauticStageBundleEntityStage.php): failed to open stream: No such file or directory in /var/www/html/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209, referer: https://13.114.212.68/s/login
[Wed Oct 25 08:30:26.615264 2017] [:error] [pid 3345] [client 210.170.194.219:52779] PHP Fatal error:  require(): Failed opening required '/var/www/html/app/cache/prod/doctrine/orm/Proxies/__CG__MauticStageBundleEntityStage.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/html/vendor/doctrine/common/lib/Doctrine/Common/Proxy/AbstractProxyFactory.php on line 209, referer: https://13.114.212.68/s/login

そもそも

最新版で動く様に使って欲しいなと思う次第です。